eSign for Confluence issues processing signature data containing extended unicode characters
Incident Report for Digital Rose
Resolved
Atlassian has corrected the encoding problem with the Atlassian API and eSign for Confluence app is operating normally. See the Atlassian incident at https://developer.status.atlassian.com/incidents/c7jqd0nhmywr for technical details.

Recovery:
Confluence pages containing signatures that included extended unicode characters and were modified between Feb 10 and 12 may have been corrupted. An error message like "The Signature data for this page is inaccessible", or failure messages on verification reports will indicate this problem.

With the signature data integrity compromised, it is not possible to sign or modify these corrupted data as is. It is possible to reset and recapture signatures for the affected pages. To do so, first use the Administrative action > Remove All Signature Data to reset signature data, then repeat the invitations and signatures. The eSign audit history in the comment chain is accessible and maybe useful to confirm who had historically signed the page.

Please contact eSign support if you have any additional questions.
Posted Feb 12, 2024 - 20:19 MST
Update
Atlassian has confirmed the problem with API character encoding and raised an incident here: https://developer.status.atlassian.com/incidents/c7jqd0nhmywr
Posted Feb 12, 2024 - 14:24 MST
Update
Continuing to work with Atlassian on identifying what Confluence API change caused this problem.
Posted Feb 12, 2024 - 13:28 MST
Identified
Bug with the Confluence Page properties API has been documented and shared with the Atlassian support team.

Waiting on Atlassian for ETA to revert or correct the API change made over the weekend.
Posted Feb 12, 2024 - 08:05 MST
Investigating
eSign is currently unable to process signature data changes for customers with extended Unicode characters in their account names and titles.

Preliminary investigation is that an apparent change to the Confluence API on Feb 10, 2024 is causing any stored data containing these types of characters to be mutated on storage in Confluence.

No impact to read only operations.

Incident has been escalated to Atlassian support for confirmation.
Posted Feb 12, 2024 - 05:18 MST
This incident affected: eSign for Confluence API.